Page 2 of 3

estoolkit 2.0

Posted: February 22nd, 2007, 3:09 pm
by patchets
It seems that either Photoshop CS3 beta or Lightroom 1.0 has installed estoolkit 2.0 and this script gives me "FATAl ERROR: XPEP launch info mismatch!"

Is there anyway you could make a version that works with the estoolkit 2.0?


Posted: February 22nd, 2007, 4:11 pm
by lloydalvarez
Hey patchets,

can you give me more information? what platform are you running? when exactly do you get this error?

FATAl ERROR: XPEP launch info mismatch!"

Posted: February 26th, 2007, 1:48 pm
by bcharles
Photoshop CS3 Beta installs a version of the ES toolkit which screws things up. Remove the v 2 Folder from your Library (Library/Application Support/Adobe) and you should be OK.

Posted: March 9th, 2007, 9:39 am
by benu
A minor bug: the script doesn't add a '\' before an exclamation point in a file or folder name. The renderer couldn't find the file until I went into the terminal and changed all '!' to '\!' manually. cheers.
(OS X 10.4.7, AE 7.0)

aerender in french & expression

Posted: March 28th, 2007, 6:35 am
by aurelyend
hi, i have the same problem as Salvador ( hi dude !).
when i run the script, it is a french version of AE wich is launched.
and it's a bad, bad thing for all my expression...
i coulnd't find how to launch an english version of "aerender.exe"
and there is no help wioth "aerender -h"

does someone have an idea ?
or the solution ? :-)



Posted: March 28th, 2007, 4:51 pm
by nab
I don't think we can specify anything about language to aerender.

Actually I'm running an english OS, so french expressions are broken when given to aerender (as default AE is in english).

One solution might be to rewrite your expressions so that they become language independent (change "Slider" to (1), etc...).

As for the help text, "aerender.exe -h" does normally display the usage infos.

How is this different?

Posted: March 29th, 2007, 4:52 pm
by scribling
What's different about this script than simply running a render in the terminal? I've been doing that forever while I work on something else. If this is better I'd like to know why? I simply put "/pathto/aerender -project " in my .alias file and I'm good to go.

Also, I believe you can get AE to relaunch the if you have a aerender running simply by duplicating the application.

Finally, to pause the aerender or anything the termial is doing CTRL-Z. You'll see "suspended" To restart type "fg" (w/o the "") and you're going again.

Last but not least, you can pause the restart until later so you don't forget too. Start the render so you know everything is going fine. Type CTRL-Z to suspend it then type "sleep 3600 ; fg <enter>" Nothing will happen because it's now counting 3600 or however many seconds you put in until it enters the next command which is the fg to restart the render. BTW the semi colon separates the commands. You could say sleep 10 ; sleep 10 ; sleep 10 and it would be the same as sleep 30. Or command1 ; command2; command3 ...

Posted: March 30th, 2007, 6:46 am
by lloydalvarez
Hey Scribling,

Those are some excellent tips. Thanks! I think i'll add them to the help file. To answer your question, the benefit of this script vs launching the render yourself in the Terminal is that it does a bit of error checking before it launches (like checking for missing footage for example which can crash aerender), allows you to set the priority for the render process and then unque's the render items to avoid rendering them twice. It can also launch multiple instances simultaneously which can speed renders up dramatically if you have enough ram. Of course you can do all of this by hand, but the script (as most scripts do) simply allows you to do it much quicker and without having to think about it much. You also don't need to know any unix to use it. :wink:


Choosing "High" priority needs a "+" to

Posted: April 17th, 2007, 11:14 am
by scribling
When I choose "High" I get "/bin/tcsh -c "nice 0 '/Applications/Adobe ..."
This won't work and returns "tcsh: 0: Command not found."

You script simply needs to write ""/bin/tcsh -c "nice +0 '/Applications/Adobe ..." in order to work.

Just thought you'd like to know.

Posted: April 17th, 2007, 12:14 pm
by lloydalvarez
Hey Scribling,

Yeah, i caught that bug the other day and quietly fixed it. If you re-download it you should get the fixed version.


Stealthy ...

Posted: April 19th, 2007, 8:29 am
by scribling
Good script though. I like it.

BG Renderer CS3

Posted: April 26th, 2007, 1:09 pm
by lloydalvarez

If you are working with the CS3 Public Preview and want to help me test the new version of BG Renderer please contact me via PM on this board. The new version runs as an embedded panel!! It also natively incorporates multi-processing so launching multiple instances is no longer necessary.


Posted: May 9th, 2007, 12:57 am
by blies
My first post to say that I really appreciate this script !!! :)

Posted: May 26th, 2007, 6:33 am
by berniebernie
can't wait to see the new CS3 scripting improvements live !

Posted: May 28th, 2007, 8:23 am
by lloydalvarez
Hey mlk,

You can download the CS3 version of the script here: