Expressions/Scripts/Presets

Moderators: Disciple, zlovatt

 
eistiroti
Topic Author
Posts: 1
Joined: Tue Feb 23, 2016 11:22 pm

I need some help

Wed Feb 24, 2016 10:29 am

Hello everyone, I need some help with an expression error that I'm getting.

So I'm using Dan Ebberts expression to trigger animation via layer markers and I'm working with one of my peers.

The problem is that if I open the project it's working perfectly, but when my friend opens the project on her machine we're getting an error in line 1, which basically says that the layer "action" is not there, the name changed or was deleted, and I've tried to fix it in several ways, changing the layer name and updating the expression, reseting the whole rig and starting from scratch but for some reason in her machine doesn't work...

Any ideas?

Here's the expression and some screenshots so you can see.

Thanking you in advance.

Ezra.


Expression________
action = comp(name).layer("Action");

n = 0;
if (marker.numKeys > 0){
n = marker.nearestKey(time).index;
if (marker.key(n).time > time){
n--;
}
}

if (n == 0){
0
}else{
m = marker.key(n);
myComment = m.comment;
t = time - m.time;
try{
actMarker = action.marker.key(myComment);
if (action.marker.numKeys > actMarker.index){
tMax = action.marker.key(actMarker.index + 1).time - actMarker.time;
}else{
tMax = action.outPoint - actMarker.time;
}
t = Math.min(t, tMax);
actMarker.time + t;
}catch (err){
0
}
}
Attachments
Screen Shot 2016-02-24 at 09.27.10.png
Screen Shot 2016-02-24 at 09.27.10.png (74.62 KiB) Viewed 1619 times
Screen Shot 2016-02-24 at 09.26.46.png
Screen Shot 2016-02-24 at 09.26.46.png (281.1 KiB) Viewed 1619 times

Who is online

Users browsing this forum: No registered users and 2 guests