Page 1 of 1

Multi-line 'edittext' UI Component Odd Behavior in CC?

Posted: Sat May 13, 2017 3:48 pm
by IllusionSector
Hi, guys. Posting for the first time here at AEE.
I've been extensively utilizing AE's support for parameter expressions for quite some time now, but my attempt to dip toes in scripting UIs isn't off to a very good start.

Not sure why, but I can't seem to get the multi-line edittext element, which appears to work fine in CS6, to work in CC as well.
The multi-line text-input field, while not without issues, works in CS6. Notice in the dialog screenshot below how the text aligns to the top, as you'd expect:
Image
Additionally, line breaks can be set both by user during text input with the Ctr+Enter (Windows) key combination, as well as by the author in the script using the \n character (e.g. when populating the field with default text).

Now take a look at the appearance of the text field in the dialog box produced by the same script run in a CC (2017) app:
Image
To begin with, the text is vertically centered! Not only do I have no clue as to why, but I can't get it not to. Also, no matter what I try, I can't seem to accomplish a line break. The aforementioned keyboard shortcut (or its Mac counterpart) does nothing, while the mere inclusion of the \n character in the default text causes the field to render empty.

Please note that while the CC 2017 screenshot is from a Mac version of AE, the results were identical on Windows.
Here's an excerpt from the code containing the edittext portion.
var message = createMessage.add('edittext',[0, 0,120, 60], 'Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do\ eiusmod tempor incididunt ut labore et...');

It almost feels as though Adobe made changes somewhere along the line that broke things.
Could you offer a solution and, perhaps, get me up to speed if I'm missing something?

Thanks :|